Πανελλαδικές 2020: Προτεινόμενο θέμα για το μάθημα Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον

Για την καλύτερη προετοιμασία των υποψηφίων ενόψει των πανελλαδικών εξετάσεων το vima.gr παρουσιάζει προτεινόμενα θέματα για τα υπό εξέταση μαθήματα.

Για την καλύτερη προετοιμασία των υποψηφίων ενόψει των πανελλαδικών εξετάσεων το vima.gr παρουσιάζει προτεινόμενα θέματα για τα υπό εξέταση μαθήματα.

Παρακάτω μπορείτε να δείτε προτεινόμενο θέμα Πανελληνίων εξετάσεων για το μάθημα Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον.

Προτεινόμενα Θέματα

ΘΕΜΑ  Α

Α1) Απαντήστε στις παρακάτω προτάσεις με ΣΩΣΤΟ  ή  ΛΑΘΟΣ αντίστοιχα.

  • Η συγγραφή του πηγαίου προγράμματος και η διόρθωση των λαθών του γίνεται με την βοήθεια του συντάκτη.
  • Σε μια συνάρτηση μπορούμε να χρησιμοποιήσουμε την εντολή ΓΡΑΨΕ, ενώ σε μια διαδικασία όχι.
  • Ο αριθμός των τυπικών παραμέτρων κατά την κλήση ενός υποπρογράμματος πρέπει να είναι ίδιος με τον αριθμό των πραγματικών παραμέτρων στην δήλωση ενός προγράμματος.
  • Μία συνάρτηση μπορεί να δεχτεί μία μόνο παράμετρο.
  • Μετά από ένα κύριο πρόγραμμα μπορεί να υπάρξει ένα ή κανένα υποπρόγραμμα.

(Μονάδες 10)

 

Α2) Να δοθεί ο ορισμός της μεθόδου σχεδίασης αλγορίθμων «Διαίρει και Βασίλευε»

 (Μονάδες 5)

Α3) Να περιγράψετε τις κύριες λειτουργίες της στοίβας

(Μονάδες 5)

Α4) Δίνεται το παρακάτω τμήμα αλγορίθμου

Σß0

ΔΙΑΒΑΣΕ Α

ΓΙΑ Ι ΑΠΟ 10 ΜΕΧΡΙ Α

ΓΡΑΨΕ   Ι

ΣßΣ+Ι

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ Σ

  1. Να μετατραπεί σε ισοδύναμο τμήμα με τη χρήση της δομής επανάληψης ΟΣΟ…….
  2. Να μετατραπεί σε ισοδύναμο τμήμα με τη χρήση της δομής επανάληψης ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ    ……..    ΜΕΧΡΙΣ_ΟΤΟΥ

           (Μονάδες 20)

Θέμα Β

Δίνεται το παρακάτω πρόγραμμα. Ζητείται:

Α) Να γράψετε στο τετράδιο σας τις τιμές που εμφανίζονται στην οθόνη κατά την εκτέλεση του.

(Μονάδες 10)

Β) Να κατασκευάσετε το διάγραμμα ροής.

(Μονάδες 10)

 

ΠΡΟΓΡΑΜΜΑ Άσκηση

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ:Κ,Ζ,Τ ,Ι,Χ

ΑΡΧΗ

Κ <– 0

Για Ι από 1 μέχρι 14 ΜΕ ΒΗΜΑ 7

Ζ <– 0

Τ <– 0

Όσο Ζ < 2 επανάλαβε

Αν Τ >= 0 τότε

Κ <– Κ + 1

Ζ <– Ζ + 1

Τέλος_αν

Τ <– Τ + 1

ΓΡΑΨΕ Κ

Τέλος_επανάληψης

ΓΡΑΨΕ  Τ

Τέλος_επανάληψης

ΓΡΑΨΕ Ζ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Θέμα Γ

Μια εταιρία κινητής τηλεφωνίας χρεώνει τους πελάτες της κλιμακωτά σύμφωνα με τον παρακάτω πίνακα:

ΠΑΓΙΟ : 7,5 €
ΜΗΝΥΜΑΤΑΧΡΕΩΣΗ
Μέχρι 1500,015 €/μην
Από 151 και πάνω0,01 €/μην
ΧΡΟΝΟΣ ΟΜΙΛΙΑΣ (sec)ΧΡΕΩΣΗ
Xρόνος <= 3600 sec0,07 €/sec
3600sec < Xρόνος <= 7200 sec0,05 €/sec
Xρόνος > 7200sec0,02 €/sec

Να γραφτεί πρόγραμμα το οποίο θα διαβάζει τον αριθμό μηνυμάτων για ένα σύνολο συνδρομητών και το χρόνο ομιλίας σε sec (να ελεγχθεί ότι είναι θετικοί αριθμοί ή μηδέν) και θα εμφανίζει την τελική χρέωση που αναλογεί στο καθένα μέχρι να δοθεί ως είσοδος έστω μία μηδενική τιμή.

Σημείωση: Ο υπολογισμός της χρέωσης να γίνει με την βοήθεια  κατάλληλου υποπρογράμματος.

 (Μονάδες 20)

Θέμα Δ

Σε μια τάξη ΄γ λυκείου υπάρχουν 25 μαθητές. Στις τελικές εξετάσεις κάθε μαθητής γράφει 12 μαθήματα. Ζητείται:

Α) Να γραφεί πρόγραμμα το οποίο να διαβάζει τα 25 ονόματα των μαθητών, τις ονομασίες των 12 μαθημάτων στα οποία συμμετέχουν καθώς και τον βαθμό κάθε μαθητή σε κάθε μάθημα.

Β) Έπειτα να υπολογίζει με χρήση υποπρογράμματος τον μέσο όρο για κάθε μαθητή που προκύπτει από όλα τα μαθήματα.

Γ) Να εμφανίζει το όνομα του μαθητή που είχε τον μεγαλύτερο μέσο όρο (θεωρήστε ότι είναι μοναδικός).

Δ) Να βρίσκει και να εμφανίζει το ποσοστό των μαθητών που είχαν βαθμό κάτω από την βάση (μικρότερο του 10) στο μάθημα της Βιολογίας (θεωρήστε ότι το μάθημα της Βιολογίας υπάρχει στα 12 μαθήματα).

(Μονάδες 20)

Προτεινόμενες απαντήσεις

 

ΘΕΜΑ  Α

Α1) 1. Σ    2. Λ     3. Λ    4. Λ    5. Λ

Α2) Σχολικό βιβλίο πληροφορικής σελ. 68

Α3) Σχολικό βιβλίο πληροφορικής σελ. 13

Α4)  1.

Σß0

ΔΙΑΒΑΣΕ Α

Ιß10

ΟΣΟ Ι <= Α ΕΠΑΝΑΛΑΒΕ

ΓΡΑΨΕ Ι

ΣßΣ+Ι

ΙßΙ+1

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ Σ

2.

Σß0

ΔΙΑΒΑΣΕ Α

Ιß10

ΑΝ Ι<= Α ΤΟΤΕ

ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ Ι

ΣßΣ+Ι

ΙßΙ+1

ΜΕΧΡΙΣ_ΟΤΟΥ  Ι>Α

ΤΕΛΟΣ_ΑΝ

ΓΡΑΨΕ Σ

 

 

 

 

Θέμα Β

Α)

 

B)

ΠΡΟΓΡΑΜΜΑ ΆσκσησηΔΡ6
ΓραμμήΚΖΤΙΧ
5.    Κ <– 00
6.    Για Ι από 1 μέχρι 14 ΜΕ ΒΗΜΑ 71
7.      Ζ <– 00
8.      Τ <– 00
9.      Όσο Ζ < 2 επανάλαβε                        Συνθήκη: ΑΛΗΘΗΣ
11.        Αν Τ >= 0 τότεΣυνθήκη: ΑΛΗΘΗΣ
12.          Κ <– Κ + 1                1
13.          Ζ <– Ζ + 11
15.        Τ <– Τ + 1  1
16.        ΓΡΑΨΕ Κ 1
9.      Όσο Ζ < 2 επανάλαβε                        Συνθήκη: ΑΛΗΘΗΣ
11.        Αν Τ >= 0 τότεΣυνθήκη: ΑΛΗΘΗΣ
12.          Κ <– Κ + 1                2
13.          Ζ <– Ζ + 12
15.        Τ <– Τ + 1  2
16.        ΓΡΑΨΕ Κ 2
9.      Όσο Ζ < 2 επανάλαβε                        Συνθήκη: ΨΕΥΔΗΣ
18.      ΓΡΑΨΕ  Τ 2
6.    Για Ι από 1 μέχρι 14 ΜΕ ΒΗΜΑ 78
7.      Ζ <– 00
8.      Τ <– 00
9.      Όσο Ζ < 2 επανάλαβε                        Συνθήκη: ΑΛΗΘΗΣ
11.        Αν Τ >= 0 τότεΣυνθήκη: ΑΛΗΘΗΣ
12.          Κ <– Κ + 1                3
13.          Ζ <– Ζ + 11
15.        Τ <– Τ + 1  1
16.        ΓΡΑΨΕ Κ 3
9.      Όσο Ζ < 2 επανάλαβε                        Συνθήκη: ΑΛΗΘΗΣ
11.        Αν Τ >= 0 τότεΣυνθήκη: ΑΛΗΘΗΣ
12.          Κ <– Κ + 1                4
13.          Ζ <– Ζ + 12
15.        Τ <– Τ + 1  2
16.        ΓΡΑΨΕ Κ 4
9.      Όσο Ζ < 2 επανάλαβε                        Συνθήκη: ΨΕΥΔΗΣ
18.      ΓΡΑΨΕ  Τ 2
6.    Για Ι από 1 μέχρι 14 ΜΕ ΒΗΜΑ 715
20.    ΓΡΑΨΕ Ζ 2

 

Θέμα Γ

ΠΡΟΓΡΑΜΜΑ θΕΜΑ3
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: ΧΡΕΩΣΗ
ΑΚΕΡΑΙΕΣ: ΜΗΝ, ΧΡ
ΑΡΧΗ

ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ΄ΔΩΣΕ ΤΟΝ ΑΡΙΘΜΟ ΜΗΝΥΜΑΤΩΝ ΤΟΥ ΣΥΝΔΡΟΜΗΤΗ΄
ΔΙΑΒΑΣΕ ΜΗΝ
ΜΕΧΡΙΣ_ΟΤΟΥ ΜΗΝ>=0
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ΄ΔΩΣΕ ΤΑ ΔΕΥΤΕΡΟΛΕΠΤΑ ΟΜΙΛΙΑΣ ΤΟΥ ΣΥΝΔΡΟΜΗΤΗ΄
ΔΙΑΒΑΣΕ ΧΡ
ΜΕΧΡΙΣ_ΟΤΟΥ ΧΡ>=0

ΟΣΟ ΜΗΝ<>0 ΚΑΙ ΧΡ<>0 ΕΠΑΝΑΛΑΒΕ
ΧΡΕΩΣΗΧΡΕΩΣΗ_ΣΥΝΔΡΟΜΗΤΗ(ΜΗΝ,ΧΡ)
ΓΡΑΨΕ ΄Η ΧΡΕΩΣΗ ΤΟΥ ΣΥΝΔΡΟΜΗΤΗ ΕΙΝΑΙ:΄,ΧΡΕΩΣΗ

ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ ΄ΔΩΣΕ ΤΟΝ ΑΡΙΘΜΟ ΜΗΝΥΜΑΤΩΝ ΤΟΥ ΣΥΝΔΡΟΜΗΤΗ΄
ΔΙΑΒΑΣΕ ΜΗΝ
ΜΕΧΡΙΣ_ΟΤΟΥ ΜΗΝ>=0
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ΄ΔΩΣΕ ΤΑ ΔΕΥΤΕΡΟΛΕΠΤΑ ΟΜΙΛΙΑΣ ΤΟΥ ΣΥΝΔΡΟΜΗΤΗ΄
ΔΙΑΒΑΣΕ ΧΡ
ΜΕΧΡΙΣ_ΟΤΟΥ ΧΡ>=0
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ ΧΡΕΩΣΗ_ΣΥΝΔΡΟΜΗΤΗ(ΜΗΝΥΜΑΤΑ, ΧΡΟΝΟΣ):ΠΡΑΓΜΑΤΙΚΗ
ΣΤΑΘΕΡΕΣ
ΠΑΓΙΟ=7.5
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: ΜΗΝΥΜΑΤΑ, ΧΡΟΝΟΣ
ΠΡΑΓΜΑΤΙΚΕΣ: ΧΡ1, ΧΡ2
ΑΡΧΗ
ΑΝ ΧΡΟΝΟΣ<3600 ΤΟΤΕ
ΧΡ1ΧΡΟΝΟΣ*0.07
ΑΛΛΙΩΣ_ΑΝ ΧΡΟΝΟΣ<7200 ΤΟΤΕ
ΧΡ13600*0.07+(ΧΡΟΝΟΣ-3600)*0.05
ΑΛΛΙΩΣ
ΧΡ13600*0.07+3600*0.05+(ΧΡΟΝΟΣ-7200)*0.02
ΤΕΛΟΣ_ΑΝ
ΑΝ ΜΗΝΥΜΑΤΑ<=150 ΤΟΤΕ
ΧΡ2ΜΗΝΥΜΑΤΑ*0.015
ΑΛΛΙΩΣ
ΧΡ2150*0.015+(ΜΗΝΥΜΑΤΑ-150)*0.01
ΤΕΛΟΣ_ΑΝ
ΧΡΕΩΣΗ_ΣΥΝΔΡΟΜΗΤΗΧΡ1+ΧΡ2+ΠΑΓΙΟ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

 

Θέμα Δ

Πρόγραμμα θέμα4

Μεταβλητές

Πραγματικές: ΒΑΘ[25,12], ΜΟ[25], Μax, Ποσοστό

Ακέραιες: I, j, Pmax, pos, πλ

Χαρακτήρες:  ΜΑΘ[12], ΟΝ[25]

Λογικές: done

Αρχή

Για i από 1 μέχρι 12

Διάβασε ΜΑΘ[i]

Τέλος_επανάληψης

Για i από 1 μέχρι 25

Διάβασε ΟΝ[i]

Για j από 1 μέχρι 12

Εμφάνισε ‘’Δώσε βαθμό για τον μαθητή’’,ΟΝ[i],’’στο μάθημα’’, ΜΑΘ[j]

Διάβασε ΒΑΘ[j]

Τέλος_επανάληψης

Τέλος_επανάληψης

Κάλεσε ΜΕΣΟ_ΟΡΟ(ΒΑΘ,ΜΟ)

Max←ΜΟ[1]

Pmax←1

Για i από 1 μέχρι 25

Αν Μax<MO[i] τότε

Max←MO[i]

Pmax←i

Τέλος_αν

Τέλος_επανάληψης

Γράψε ‘το όνομα του μαθητή με τον μεγαλύτερο μέσο όρο είναι ’, ΜΟ[Pmax]

done←ΨΕΥΔΗΣ

pos←0

i←1

Οσό done=ΨΕΥΔΗΣ και i<=12 επανάλαβε

Αν ΜΑΘ[i]=’’Βιολογία’’ τότε

done←ΑΛΗΘΗΣ

pos←i

Αλλιώς

i←i+1

τέλος_αν

τέλος_επανάληψης

πλ←0

Για i  από 1 μέχρι 25

Αν ΒΑΘ[i,pos]<10 τότε

πλ←πλ+1

Τέλος_αν

Τέλος_επανάληψης

Ποσοστό← (πλ*100)/25

Γράψε ’το ποσοστό των μαθητών που είχαν κάτω από την βάση στο μάθημα της’,

& ’βιολογίας  είναι’,  Ποσοστό

Τέλος_Προγράμματος

Διαδικασία  ΜΕΣΟ_ΟΡΟ(Β,Μ)

Μεταβλητές

Πραγματικές: Β[25,12], Μ[25], S

Ακέραιες: I, j

Αρχή

Για i από 1 μέχρι 25

S←0

Για j από 1 μέχρι 12

S←S+ B[I,j]

Τέλος_επανάληψης

Μ[i] ←S/12

Τέλος_επανάληψης

Τέλος_Διαδικασίας

Με τη συνεργασία του φροντιστηρίου Ορόσημο Πειραιά

Κοινωνία
ΒΗΜΑτοδότης
Σίβυλλα
Helios Kiosk